Brightspace Browser Support Information

Important Notice: Upgrade from TLS 1.0 to TLS 1.1

In order to align with industry best practices, D2L will require TLS 1.1 and later encryption protocol in an effort to maintain the highest security standards and promote the safety of client data. The switch from TLS 1.0 to TLS 1.1 will occur on June 30th, 2018.

To read the complete notice from D2L, click here: https://community.brightspace.com/s/article/D2L-requires-upgrade-from-TLS-1-0-to-TLS-1-1-by-June-30-2018 

How will I be impacted? 

If your device does not support TLS 1.1 or higher prior to June 30th, 2018 any inbound connections to or outbound connections from the Brightspace instance that rely on TLS 1.0 will fail to connect.

Google devices running Android v4.4 or older, and Apple devices running iOS v6 or older may no longer be able to connect with Brightspace using their web browsers after June 30th, 2018 as they do not support TLS 1.1 or above.  See this page for web browser compatibility with TLS 1.1 or above.

What action do I need to take?

For end-user web browsing please upgrade to the latest version of your browser of choice. On mobile devices, you may need to upgrade the operating system in order to upgrade your browser. TLS 1.1 has been supported for a couple of years and can be validated by going to https://www.ssllabs.com/ssltest/viewMyClient.html and reviewing the Protocol Features section to ensure 1.1 or higher are supported.